Flash Miscellaneous Remnants

From Knowledge Kitchen
Jump to navigation Jump to search


Shape Tweening

  • Shape hints
    • allow you to specify exactly how one shape morphs into another
    • create shape hints
      • create shape tween
      • click shape in first keyframe
      • click Modify -> Shape -> Add shape hint
      • position hint in first shape tween keyframe
      • position hint in second shape tween keyframe


Mask layers

  • allow you to indicate what parts of a layer should be transparent, and what parts should be opaque
    • just like in Photoshop
  • create a layer with some regular shapes in it
  • create another layer just above that layer
  • right click on the new layer and select Mask
  • unlock the Mask layer
  • draw the mask using the usual shape drawing tools
  • lock the Mask layer


Sound

Sound an be added as background noise, or as sound effects at particular moments in your movies

To add a sound to your movie:

The first way to add sound

  1. import a sound file to the Library
  2. make a new layer to manage sounds
  3. create a keyframe where you want the sound to start playing
  4. in the Properties panel for that keyframe, select the Sound name that you imported.

The second way to add sound

  1. click File -> Import -> Import to Stage
  2. select the file to import
  3. make a new layer that will hold the sound
  4. once imported, find the file in the Library Panel
  5. drag it onto the stage in the keyframe where you want it to go


Video

  • can be added to your projects and placed on the stage
  • imported files must be in FLV or M4V video format
    • FLV format
      • Flash movies can be saved as FLV format, meaning you can import one flash movie inside another
      • you can convert other video file types to FLV using a transcoder tool, such as FFmpeg, which is free and open source
    • M4V format
      • Movies imported into iTunes are usually auto-converted to M4v
        • so you can probably use any movie you have in iTunes
  • add a movie
    • File -> Import -> Import Video'
    • select file and select 'Load external video
    • select skin (a.k.a look and feel)


Publishing

  • File -> Publish Settings
  • set format to .SWF
  • set output file name and location
  • File -> Publish Preview
  • File -> Publish


Example

Bee story

This example shows a variety of techniques necessary to complete a Flash animation with interactive buttons. Notice that all components are divided nicely into separate layers.

Goat vs. Earth

This example shows the usage of Actionscript to stop and start the animation at different points in the timeline. Notice the 'Actions' layer has keyframes' these have embedded Actionscript code. Go to the Window->Actions menu while the desired keyframe is selected to view the code.

Download the Goat versus Earth Flash source file here: File:Actionscript start stop example fall 2013.zip.


What links here