Flash Tweens and Inner Timelines

From Knowledge Kitchen
Jump to navigation Jump to search


Shape tweening

  • used to animate changes in the shape of a graphic element
  • can also animate changes in color, size and location of graphic elements
  • can work with shapes created in Merge Mode, Drawing Mode, or Primitive Mode
  • doesn't work with symbols
    • whereas Classic Tweening works only with symbols
    • because symbols can't have their shape changed
  • create a Shape Tween
    • create a keyframe
    • draw an object in the keyframe
    • make a second keyframe
    • draw an object in the second keyframe that differs in some way from the object in the first keyframe
    • click on the first keyframe
    • select Insert -> Shape Tween

Motion tweening

  • used to do movement animations
  • work only with symbols

create a motion tween

  • create a keyframe
  • draw a symbol in the keyframe
  • create a new regular frame somewhere further down the timeline
  • click the symbol
  • select Insert -> Motion Tween
  • click on of the regular frames further down the timeline
  • move the symbol to a new location
  • move again in any other frames where you want changes

modify the path of a motion tween

  • use the Selection Tool to click and drag the path to a new location
  • use the Subselecton Tool to click and drag anchors of the path to new locations
  • Option-Click and drag anchors to convert them into curved paths

orient symbol to path

  • click on path
  • in Properties Inspector Panel, click Orient to Path checkbox

Motion editor

  • click Window -> Motion Editor
  • use it to modify advanced animation properties

Buttons

  • are symbols you can make
  • have their own internal timeline
    • a button timeline consists of four possible keyframes:
      • Up
      • Over
      • Down
      • Hit

create a button

  • click Insert -> New Symbol'
  • Select button type, name your symbol, and click Ok
  • in the Timeline, create keyframes for Up, Over, Down, and Hit
  • create variations of a single shape within each keyframe
  • click the back arrow at the top-left of the window to return to the Stage
  • the Button symbol you created now shows up in the Library Panel
  • click and drag it onto the stage
  • Preview the behavior of the button
    • click File -> Publish Preview

Examples


What links here