Rhino 3d modeling basic concepts

From Knowledge Kitchen
Jump to navigation Jump to search


Rhino is based on AutoCAD... it used to be an AutoCAD plugin


3d rendering concepts

Friendly advice:

  • get a 3-button mouse or suffer the consequences

Control points

  • anchors from which paths are generated in 3d

Transformations:

  • translating = moving something
  • rotating = rotating around an axis
  • scaling = changing the size, either uniformly or along an axis

View port modes:

  • change view modes in View menu
  • wireframe - shows you an outline of all curves, isocurves, and segments

Gumball

  • tab at the top of the window
  • square anchros allow you to stretch an object along each axis
  • arcs allow you to rotate around each axis

Units

  • 'units' command... let's you set the units of measure in Rhino
  • you can scale up and down

Documentation

Command help:

  • Help -> Command Help
  • shows documentation on each command

Nice rhino settings to have

  • Preferences -> Display Modes -> Shaded -> General... select Backface settings to 'single color for all backfaces' - select a nice color. This colors the back face settings differently than the front face color
  • select History tab at top of window... keeps history of commands


Commands

Space bar repeats the last command

Zoom command

  • type 'zoom', then hit enter
  • select 'extent' to fit everything on screen
  • select 'selected' to zoom selected object into focus

Line command

  • type 'line', then hit enter
  • click to draw each of the beginning and ending anchors

Polyline command

  • multi-anchor lines
  • hit enter to finish the line
  • ... or click the 'close' button to cmoplete a closed loop shape

Curve command

  • similar to polyline, but has curvy anchors

Copy command

  • can easily copy only along one axis, such as vertically

PointsOn command

  • select an object
  • type 'PointsOn' command
  • makes points appear with dotted lines betwen them on all shapes
  • allows you to move around the control points... like moving anchors in illustrator

2d shape primitives

  • circle command
  • rectangle command
  • etc...

Transformation commands:

  • 'move' - specify the origin and target points of the transformation
  • 'rotate' - rotates around the point that you select
  • 'scale' - first click center of selected object, then click to make a reference point, then scale with mouse in all directions
  • 'scale1d' - scales on only one axis, rather than maintaining proportions

Extrude

  • 'extrudecrv' - extrude an existing curve
  • stretches out a shape along a second axis
  • closed shapes, if you extrude them, will automatically have caps attached on top and bottom
  • if you don't want the caps, toggle the 'solid' checkbox

Flip

  • select an object and type 'flip'... flips the front and back faces of that object

Pipe

  • select a path, type 'pipe', specify start and end radiuses
  • can add additional anchors with different diameters in the middle

Revolve

  • select a curve to revolve, then type 'revolve'
  • select start angle and revolution angle. this stretches/revolves that shape around a given axis
  • good for objects with radial symmetry

Loft

  • type 'loft'
  • select several curves
  • hit enter... a lofting surface will connect them

Sweeping

  • sweeps a curve profile along a 'rail'
  • type 'sweep1'
  • select a curve as a 'rail'
  • select other curves as 'cross-section curves'... these represent cross-sections at various points along the rail
  • hit enter.. select 'freeform' style
  • 'sweep2' allows the same thing, but with two rails

3d primitives

  • box, cylinder, tube, spehere, etc.
  • work as expected

Boolean operations

  • commands for combining multiple shapes in various ways
  • 'booleanunion' to merge two shapes together
  • 'booleandifference' can indicate that one shape should be subtracted from another
  • as expected for other boolean operations: 'booleanintersection', 'booleansplit', etc

Twist:

  • takes a 3d shape and twists it
  • make sure 'midpoint is selected' in optinos
  • click on midpoint of one of the bottom edges of shape
  • click on midpoint of top edge of shape
  • then start twisting

Bend

  • draw a 3d shape
  • specficy start of spine by clicking on a bottom corner
  • click on end of spine on top corner
  • then start bending

Types of geometry

Two types of 3d geometry

  • mesh and NURBS
  • rhino uses nurbs by default

NURBS geometry - "non-uniform bezier splines"

  • e.g. bezier splines and bezier surfaces
  • all control points are controllable
  • you can 'rebuild' complex surfaces to give you many more control points - 'rebuild' command

Mesh geometry

  • also control points in space
  • meshes are a set of triangular or rectangular faces that are connecting all points in space
  • to get more detail you need to include more vertices in your geometry
  • no implicit curvature in mesh geometry
  • meshes are generally more efficient for performance

Easy to switch between types

  • often when exporting from Rhino, you need to convert from NURB to Mesh geometry for other apps
  • can convert a nurb to mesh within Rhino via menu: Mesh -> From Nurbs Object

Importing / Exporting

Exporting

  • 'export' command allows you to also export as mesh... 'obj' format is common format
  • select checkbox that says 'map rhino z to obj y', since the axes are different in rhino from usual
  • can twiddle with the # of polygons in mesh to make sure it's detailed enough for us

Importing

  • can open obj file up in Cura or Makerbot for 3d printing
  • can drag and place into Unity scenes for game development